CVE-2014-0162

NameCVE-2014-0162
DescriptionThe Sheepdog backend in OpenStack Image Registry and Delivery Service (Glance) 2013.2 before 2013.2.4 and icehouse before icehouse-rc2 allows remote authenticated users with permission to insert or modify an image to execute arbitrary commands via a crafted location.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glance (PTS)buster2:17.0.0-4fixed
buster (security)2:17.0.0-5+deb10u1fixed
bullseye2:21.0.0-2fixed
bullseye (security)2:21.0.0-2+deb11u1fixed
bookworm, sid2:25.0.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glancesourcewheezy(not affected)
glancesource(unstable)2014.1-1

Notes

[wheezy] - glance <not-affected> (Only affects 2013.2 to 2013.2.3)

Search for package or bug name: Reporting problems