CVE-2014-0172

NameCVE-2014-0172
DescriptionInteger overflow in the check_section function in dwarf_begin_elf.c in the libdw library, as used in elfutils 0.153 and possibly through 0.158 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a malformed compressed debug section in an ELF file, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs744017

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
elfutils (PTS)jessie0.159-4.2fixed
jessie (security)0.159-4.2+deb8u1fixed
stretch0.168-1fixed
bullseye, sid, buster0.176-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
elfutilssource(unstable)0.158-1low744017
elfutilssourcesqueeze(not affected)
elfutilssourcewheezy(not affected)

Notes

[squeeze] - elfutils <not-affected> (Affected code introduced in 0.153)
[wheezy] - elfutils <not-affected> (Affected code introduced in 0.153)

Search for package or bug name: Reporting problems