CVE-2014-0181

NameCVE-2014-0181
DescriptionThe Netlink implementation in the Linux kernel through 3.14.1 does not provide a mechanism for authorizing socket operations based on the opener of a socket, which allows local users to bypass intended access restrictions and modify network configurations by using a Netlink socket for the (1) stdout or (2) stderr of a setuid program.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)
Debian Bugs746738

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1vulnerable
wheezy (security)3.2.96-3vulnerable
jessie3.16.51-2fixed
jessie (security)3.16.51-3+deb8u1fixed
stretch4.9.65-3fixed
stretch (security)4.9.65-3+deb9u2fixed
buster, sid4.14.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)3.14.9-1low746738
linux-2.6source(unstable)(unfixed)low

Notes

[squeeze] - linux-2.6 <no-dsa> (Too intrusive to backport to 2.6.32)
[wheezy] - linux <no-dsa> (Too intrusive to backport to 3.2)

Search for package or bug name: Reporting problems