CVE-2014-0193

NameCVE-2014-0193
DescriptionWebSocket08FrameDecoder in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19 allows remote attackers to cause a denial of service (memory consumption) via a TextWebSocketFrame followed by a long stream of ContinuationWebSocketFrames.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2110-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netty (PTS)stretch1:4.1.7-2+deb9u1fixed
stretch (security)1:4.1.7-2+deb9u2fixed
buster, buster (security)1:4.1.33-1+deb10u1fixed
bullseye, sid1:4.1.48-1fixed
netty-3.9 (PTS)stretch3.9.9.Final-1fixed
stretch (security)3.9.9.Final-1+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nettysource(unstable)(not affected)
netty-3.9sourcejessie3.9.0.Final-1+deb8u1DLA-2110-1
netty-3.9source(unstable)3.9.9.Final-1

Notes

- netty <not-affected> (WebSocket08FrameDecoder function not present; bug #746639)
https://github.com/netty/netty/commit/48edb7802b42b0e2eb5a55d8eca390e0c9066783

Search for package or bug name: Reporting problems