CVE-2014-0195

NameCVE-2014-0195
DescriptionThe dtls1_reassemble_fragment function in d1_both.c in OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly validate fragment lengths in DTLS ClientHello messages, which allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) via a long non-initial fragment.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-0003-1, DSA-2950-1
NVD severitymedium (attack range: remote)
Debian Bugs750665
Debian/oldstablepackage openssl is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)squeeze (security), squeeze0.9.8o-4squeeze14vulnerable
squeeze (lts)0.9.8o-4squeeze19fixed
wheezy1.0.1e-2+deb7u13fixed
wheezy (security)1.0.1e-2+deb7u14fixed
jessie, sid1.0.1k-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)1.0.1h-1medium750665
opensslsourcesqueeze0.9.8o-4squeeze15medium
opensslsourcewheezy1.0.1e-2+deb7u10mediumDSA-2950-1

Search for package or bug name: Reporting problems