CVE-2014-0209

NameCVE-2014-0209
DescriptionMultiple integer overflows in the (1) FontFileAddEntry and (2) lexAlias functions in X.Org libXfont before 1.4.8 and 1.4.9x before 1.4.99.901 might allow local users to gain privileges by adding a directory with a large fonts.dir or fonts.alias file to the font path, which triggers a heap-based buffer overflow, related to metadata.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2927-1
NVD severitymedium (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxfont (PTS)squeeze (security), squeeze1:1.4.1-5fixed
squeeze (lts)1:1.4.1-5+deb6u1fixed
wheezy1:1.4.5-4fixed
wheezy (security)1:1.4.5-5fixed
jessie, sid1:1.5.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxfontsource(unstable)1:1.4.7-2medium
libxfontsourcesqueeze1:1.4.1-5mediumDSA-2927-1
libxfontsourcewheezy1:1.4.5-4mediumDSA-2927-1

Search for package or bug name: Reporting problems