CVE-2014-0210

NameCVE-2014-0210
DescriptionMultiple buffer overflows in X.Org libXfont before 1.4.8 and 1.4.9x before 1.4.99.901 allow remote font servers to execute arbitrary code via a crafted xfs protocol reply to the (1) _fs_recv_conn_setup, (2) fs_read_open_font, (3) fs_read_query_info, (4) fs_read_extent_info, (5) fs_read_glyphs, (6) fs_read_list, or (7) fs_read_list_info function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2927-1
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxfont (PTS)squeeze (security), squeeze1:1.4.1-5fixed
wheezy, wheezy (security)1:1.4.5-4fixed
jessie, sid1:1.4.99.901-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxfontsource(unstable)1:1.4.7-2unimportant
libxfontsourcesqueeze1:1.4.1-5highDSA-2927-1
libxfontsourcewheezy1:1.4.5-4highDSA-2927-1

Notes

unimportant, as source affected but libxfont has disabled support to connect to font server since 1:1.4.7-1

Search for package or bug name: Reporting problems