CVE-2014-0211

NameCVE-2014-0211
DescriptionMultiple integer overflows in the (1) fs_get_reply, (2) fs_alloc_glyphs, and (3) fs_read_extent_info functions in X.Org libXfont before 1.4.8 and 1.4.9x before 1.4.99.901 allow remote font servers to execute arbitrary code via a crafted xfs reply, which triggers a buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2927-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxfont (PTS)squeeze, squeeze (security)1:1.4.1-5fixed
squeeze (lts)1:1.4.1-5+deb6u1fixed
wheezy1:1.4.5-4fixed
wheezy (security)1:1.4.5-5fixed
stretch, sid, jessie1:1.5.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxfontsource(unstable)1:1.4.7-2unimportant
libxfontsourcesqueeze1:1.4.1-5highDSA-2927-1
libxfontsourcewheezy1:1.4.5-4highDSA-2927-1

Notes

unimportant, as source affected but libxfont has disabled support to connect to font server since 1:1.4.7-1

Search for package or bug name: Reporting problems