CVE-2014-0236

NameCVE-2014-0236
Descriptionfile before 5.18, as used in the Fileinfo component in PHP before 5.6.0, allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a zero root_storage value in a CDF file, related to cdf.c and readcdf.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)stretch (security), stretch1:5.30-1+deb9u3fixed
buster, buster (security)1:5.35-4+deb10u1fixed
bullseye1:5.38-5fixed
sid1:5.39-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesourcesqueeze(not affected)
filesourcewheezy(not affected)
filesource(unstable)1:5.19-1
php5sourcesqueeze(not affected)
php5sourcewheezy(not affected)
php5source(unstable)5.6.0~beta4+dfsg-1

Notes

[wheezy] - file <not-affected> (Introduced in 5.18)
[squeeze] - file <not-affected> (Introduced in 5.18)
[wheezy] - php5 <not-affected> (Vulnerable code not present)
[squeeze] - php5 <not-affected> (Vulnerable code not present)
https://bugs.php.net/bug.php?id=67329

Search for package or bug name: Reporting problems