CVE-2014-0244

NameCVE-2014-0244
DescriptionThe sys_recvfrom function in nmbd in Samba 3.6.x before 3.6.24, 4.0.x before 4.0.19, and 4.1.x before 4.1.9 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a malformed UDP packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2966-1
NVD severitylow (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)squeeze, squeeze (security)2:3.5.6~dfsg-3squeeze11fixed
squeeze (lts)2:3.5.6~dfsg-3squeeze12fixed
wheezy2:3.6.6-6+deb7u4fixed
wheezy (security)2:3.6.6-6+deb7u5fixed
jessie2:4.1.17+dfsg-2fixed
stretch, sid2:4.1.17+dfsg-4fixed
samba4 (PTS)wheezy4.0.0~beta2+dfsg1-3.2+deb7u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.1.9+dfsg-1low
sambasourcesqueeze(not affected)
sambasourcewheezy2:3.6.6-6+deb7u4lowDSA-2966-1
samba4source(unstable)4.0.0~beta2+dfsg1-3.2+deb7u2low

Notes

[squeeze] - samba <not-affected> (Only affects 3.6 and later)
AD-related packages removed from src:samba4 in 4.0.0~beta2+dfsg1-3.2+deb7u2
https://www.samba.org/samba/security/CVE-2014-0244

Search for package or bug name: Reporting problems