CVE-2014-0466

NameCVE-2014-0466
DescriptionThe fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2892-1
NVD severitymedium (attack range: remote)
Debian Bugs742902
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
a2ps (PTS)squeeze (security), squeeze1:4.14-1.1+deb6u1fixed
wheezy, wheezy (security)1:4.14-1.1+deb7u1fixed
jessie, sid1:4.14-1.3fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
a2pssource(unstable)1:4.14-1.3medium742902
a2pssourcesqueeze1:4.14-1.1+deb6u1mediumDSA-2892-1
a2pssourcewheezy1:4.14-1.1+deb7u1mediumDSA-2892-1

Search for package or bug name: Reporting problems