CVE-2014-0475

NameCVE-2014-0475
DescriptionMultiple directory traversal vulnerabilities in GNU C Library (aka glibc or libc6) before 2.20 allow context-dependent attackers to bypass ForceCommand restrictions and possibly have other unspecified impact via a .. (dot dot) in a (1) LC_*, (2) LANG, or other locale environment variable.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-43-1, DSA-2976-1
NVD severitymedium (attack range: remote)
Debian/oldstablepackage eglibc is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)squeeze2.11.3-4vulnerable
squeeze (lts)2.11.3-4+deb6u5fixed
wheezy2.13-38+deb7u6fixed
wheezy (security)2.13-38+deb7u8fixed
glibc (PTS)jessie2.19-15fixed
sid2.19-17fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)medium
eglibcsourcesqueeze2.11.3-4+deb6u1mediumDLA-43-1
eglibcsourcewheezy2.13-38+deb7u3mediumDSA-2976-1
glibcsource(unstable)2.19-6medium

Search for package or bug name: Reporting problems