CVE-2014-0478

NameCVE-2014-0478
DescriptionAPT before 1.0.4 does not properly validate source packages, which allows man-in-the-middle attackers to download and install Trojan horse packages by removing the Release signature.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-0005-1, DSA-2958-1
NVD severitymedium (attack range: remote)
Debian Bugs749795
Debian/oldstablepackage apt is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apt (PTS)squeeze0.8.10.3+squeeze1vulnerable
squeeze (lts)0.8.10.3+squeeze7fixed
wheezy0.9.7.9+deb7u7fixed
wheezy (security)0.9.7.9+deb7u6fixed
sid, jessie1.0.9.8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aptsource(unstable)1.0.4medium749795
aptsourcesqueeze0.8.10.3+squeeze2medium
aptsourcewheezy0.9.7.9+deb7u2mediumDSA-2958-1

Search for package or bug name: Reporting problems