CVE-2014-0488

NameCVE-2014-0488
DescriptionAPT before 1.0.9 does not "invalidate repository data" when moving from an unauthenticated to authenticated state, which allows remote attackers to have unspecified impact via crafted repository data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-53-1, DSA-3025-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apt (PTS)wheezy0.9.7.9+deb7u7fixed
wheezy (security)0.9.7.9+deb7u6fixed
jessie (security), jessie1.0.9.8.4fixed
stretch1.4.8fixed
buster, sid1.5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aptsource(unstable)1.0.9medium
aptsourcesqueeze0.8.10.3+squeeze3mediumDLA-53-1
aptsourcewheezy0.9.7.9+deb7u3mediumDSA-3025-1

Search for package or bug name: Reporting problems