CVE-2014-0490

NameCVE-2014-0490
DescriptionThe apt-get download command in APT before 1.0.9 does not properly validate signatures for packages, which allows remote attackers to execute arbitrary code via a crafted package.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3025-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apt (PTS)stretch (security), stretch1.4.10fixed
buster, buster (security)1.8.2.1fixed
bullseye, sid2.1.10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aptsourcesqueeze(not affected)
aptsourcewheezy0.9.7.9+deb7u3DSA-3025-1
aptsource(unstable)0.9.12

Notes

fixed with commit http://anonscm.debian.org/cgit/apt/apt.git/commit/?id=d57f6084aaa3972073114973d149ea2291b36682
[squeeze] - apt <not-affected> (apt download command and vulnerable code not present)

Search for package or bug name: Reporting problems