CVE-2014-10070

NameCVE-2014-10070
Descriptionzsh before 5.0.7 allows evaluation of the initial values of integer variables imported from the environment (instead of treating them as literal numbers). That could allow local privilege escalation, under some specific and atypical conditions where zsh is being invoked in privilege-elevation contexts when the environment has not been properly sanitized, such as when zsh is invoked by sudo on systems where "env_reset" has been disabled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1304-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zsh (PTS)jessie5.0.7-5fixed
stretch5.3.1-4fixed
bullseye, sid, buster5.7.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zshsource(unstable)5.0.7-3
zshsourcewheezy4.3.17-1+deb7u1DLA-1304-1

Notes

https://sourceforge.net/p/zsh/code/ci/546203a770cec329e73781c3c8ab1078390aee72

Search for package or bug name: Reporting problems