CVE-2014-10072

NameCVE-2014-10072
DescriptionIn utils.c in zsh before 5.0.6, there is a buffer overflow when scanning very long directory paths for symbolic links.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1304-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zsh (PTS)stretch5.3.1-4fixed
buster5.7.1-1fixed
bullseye, sid5.8-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zshsourcewheezy4.3.17-1+deb7u1DLA-1304-1
zshsource(unstable)5.0.6-1

Notes

https://sourceforge.net/p/zsh/code/ci/3e06aeabd8a9e8384ebaa8b08996cd1f64737210

Search for package or bug name: Reporting problems