CVE-2014-1447

NameCVE-2014-1447
DescriptionRace condition in the virNetServerClientStartKeepAlive function in libvirt before 1.2.1 allows remote attackers to cause a denial of service (libvirtd crash) by closing a connection before a keepalive response is sent.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2846-1
NVD severitylow (attack range: remote)
Debian Bugs735676
Debian/oldstablepackage libvirt is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvirt (PTS)squeeze (security), squeeze0.8.3-5+squeeze5vulnerable
wheezy, wheezy (security)0.9.12.3-1+deb7u1fixed
jessie1.2.9-9fixed
sid1.2.9-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvirtsource(unstable)1.2.1-1low735676
libvirtsourcesqueeze(unfixed)end-of-life
libvirtsourcewheezy0.9.12.3-1lowDSA-2846-1

Notes

[squeeze] - libvirt <end-of-life> (Unsupported in squeeze-lts)
https://bugzilla.redhat.com/show_bug.cgi?id=1047577
http://libvirt.org/git/?p=libvirt.git;a=commit;h=066c8ef6c18bc1faf8b3e10787b39796a7a06cc0
http://libvirt.org/git/?p=libvirt.git;a=commit;h=173c2914734eb5c32df6d35a82bf503e12261bcf

Search for package or bug name: Reporting problems