CVE-2014-1491

NameCVE-2014-1491
DescriptionMozilla Network Security Services (NSS) before 3.15.4, as used in Mozilla Firefox before 27.0, Firefox ESR 24.x before 24.3, Thunderbird before 24.3, SeaMonkey before 2.24, and other products, does not properly restrict public values in Diffie-Hellman key exchanges, which makes it easier for remote attackers to bypass cryptographic protection mechanisms in ticket handling by leveraging use of a certain value.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-23-1, DSA-2858-1, DSA-2994-1
NVD severitymedium (attack range: remote)
Debian/oldstablepackages icedove, iceweasel, nss are vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)squeeze (security), squeeze3.0.11-1+squeeze15vulnerable
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.4.0-1~deb7u1fixed
jessie31.4.0-2fixed
sid31.5.0-1fixed
iceweasel (PTS)squeeze (security), squeeze3.5.16-20vulnerable
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.5.0esr-1~deb7u1fixed
jessie, sid31.5.0esr-1fixed
nss (PTS)squeeze (security), squeeze3.12.8-1+squeeze7vulnerable
squeeze (lts)3.12.8-1+squeeze11fixed
wheezy, wheezy (security)2:3.14.5-1+deb7u3fixed
jessie, sid2:3.17.2-1.1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)24.3.0-1medium
icedovesourcesqueeze(unfixed)end-of-life
iceweaselsource(unstable)24.3.0esr-1medium
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy24.3.0esr-1~deb7u1mediumDSA-2858-1
nsssource(unstable)2:3.15.4-1medium
nsssourcesqueeze3.12.8-1+squeeze8medium
nsssourcewheezy2:3.14.5-1+deb7u1mediumDSA-2994-1

Search for package or bug name: Reporting problems