CVE-2014-1508

NameCVE-2014-1508
DescriptionThe libxul.so!gfxContext::Polygon function in Mozilla Firefox before 28.0, Firefox ESR 24.x before 24.4, Thunderbird before 24.4, and SeaMonkey before 2.25 allows remote attackers to obtain sensitive information from process memory, cause a denial of service (out-of-bounds read and application crash), or possibly bypass the Same Origin Policy via vectors involving MathML polygon rendering.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2881-1, DSA-2911-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablepackages icedove, iceweasel are vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)squeeze, squeeze (security)3.0.11-1+squeeze15vulnerable
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.7.0-1~deb7u1fixed
jessie31.6.0-1fixed
jessie (security)31.7.0-1~deb8u1fixed
stretch, sid31.7.0-1fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20vulnerable
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.7.0esr-1~deb7u1fixed
jessie31.6.0esr-1fixed
jessie (security)31.7.0esr-1~deb8u1fixed
stretch38.0.1-1fixed
sid38.0.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)24.4.0-1medium
icedovesourcesqueeze(unfixed)end-of-life
icedovesourcewheezy24.4.0-1~deb7u1mediumDSA-2911-1
iceweaselsource(unstable)24.4.0esr-1medium
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy24.4.0esr-1~deb7u2mediumDSA-2881-1

Search for package or bug name: Reporting problems