CVE-2014-1510

NameCVE-2014-1510
DescriptionThe Web IDL implementation in Mozilla Firefox before 28.0, Firefox ESR 24.x before 24.4, Thunderbird before 24.4, and SeaMonkey before 2.25 allows remote attackers to execute arbitrary JavaScript code with chrome privileges by using an IDL fragment to trigger a window.open call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2881-1, DSA-2911-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)jessie1:52.3.0-4~deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)24.4.0-1
icedovesourcesqueeze(unfixed)end-of-life
icedovesourcewheezy24.4.0-1~deb7u1DSA-2911-1
iceweaselsource(unstable)24.4.0esr-1
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy24.4.0esr-1~deb7u2DSA-2881-1

Search for package or bug name: Reporting problems