CVE-2014-1530

NameCVE-2014-1530
DescriptionThe docshell implementation in Mozilla Firefox before 29.0, Firefox ESR 24.x before 24.5, Thunderbird before 24.5, and SeaMonkey before 2.26 allows remote attackers to trigger the loading of a URL with a spoofed baseURI property, and conduct cross-site scripting (XSS) attacks, via a crafted web site that performs history navigation.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2918-1, DSA-2924-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldstablepackages icedove, iceweasel are vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)squeeze (security), squeeze3.0.11-1+squeeze15vulnerable
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.6.0-1~deb7u1fixed
sid, jessie31.6.0-1fixed
iceweasel (PTS)squeeze (security), squeeze3.5.16-20vulnerable
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.6.0esr-1~deb7u1fixed
sid, jessie31.6.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)24.5.0-1medium
icedovesourcesqueeze(unfixed)end-of-life
icedovesourcewheezy24.5.0-1~deb7u1mediumDSA-2924-1
iceweaselsource(unstable)24.5.0esr-1medium
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy24.5.0esr-1~deb7u1mediumDSA-2918-1

Search for package or bug name: Reporting problems