CVE-2014-1724

NameCVE-2014-1724
DescriptionUse-after-free vulnerability in Free(b)soft Laboratory Speech Dispatcher 0.7.1, as used in Google Chrome before 34.0.1847.116, allows remote attackers to cause a denial of service (application hang) or possibly have unspecified other impact via a text-to-speech request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2905-1
NVD severityhigh (attack range: remote)
Debian Bugs745808

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch63.0.3239.84-1~deb9u1fixed
stretch (security)67.0.3396.87-1~deb9u1fixed
buster, sid67.0.3396.87-1fixed
speech-dispatcher (PTS)jessie0.8-7fixed
stretch0.8.6-4+deb9u1fixed
buster, sid0.8.8-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)34.0.1847.116-1high
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersourcewheezy34.0.1847.116-1~deb7u1highDSA-2905-1
speech-dispatchersource(unstable)0.8-7low745808

Notes

[squeeze] - speech-dispatcher <no-dsa> (Minor issue)
[wheezy] - speech-dispatcher <no-dsa> (Minor issue)
no specific information available (possibly already be fixed in 0.8), the fix in chromium was to disable speechd by default

Search for package or bug name: Reporting problems