CVE-2014-1831

NameCVE-2014-1831
DescriptionPhusion Passenger before 4.0.37 allows local users to write to certain files and directories via a symlink attack on (1) control_process.pid or a (2) generation-* file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)
Debian Bugs736958

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
passenger (PTS)buster, sid, stretch5.0.30-1fixed
ruby-passenger (PTS)jessie4.0.53-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
passengersource(unstable)4.0.37-1low
ruby-passengersource(unstable)4.0.37-1low736958
ruby-passengersourcewheezy3.0.13debian-1+deb7u2low736958

Notes

[squeeze] - passenger <no-dsa> (minor issue)

Search for package or bug name: Reporting problems