CVE-2014-1832

NameCVE-2014-1832
DescriptionPhusion Passenger 4.0.37 allows local users to write to certain files and directories via a symlink attack on (1) control_process.pid or a (2) generation-* file. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-1831.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
passenger (PTS)bullseye5.0.30-1.2+deb11u1fixed
bookworm6.0.17+ds-1fixed
sid, trixie6.0.20+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
passengersource(unstable)(not affected)
ruby-passengersourcewheezy(not affected)
ruby-passengersource(unstable)4.0.37-2

Notes

[wheezy] - ruby-passenger <not-affected> (incomplete patch never applied)
- passenger <not-affected> (incomplete patch never applied)

Search for package or bug name: Reporting problems