CVE-2014-1833

NameCVE-2014-1833
DescriptionDirectory traversal vulnerability in uupdate in devscripts 2.14.1 allows remote attackers to modify arbitrary files via a crafted .orig.tar file, related to a symlink.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs737160

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
devscripts (PTS)bullseye2.21.3+deb11u1fixed
bookworm2.23.4+deb12u1fixed
sid, trixie2.23.7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
devscriptssource(unstable)2.14.8low737160

Notes

[squeeze] - devscripts <no-dsa> (Minor issue)
[wheezy] - devscripts <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems