CVE-2014-1904

NameCVE-2014-1904
DescriptionCross-site scripting (XSS) vulnerability in web/servlet/tags/form/FormTag.java in Spring MVC in Spring Framework 3.0.0 before 3.2.8 and 4.0.0 before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via the requested URI in a default action.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2890-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs741604
Debian/oldoldstablenot known to be vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspring-java (PTS)wheezy, wheezy (security)3.0.6.RELEASE-6+deb7u3fixed
jessie3.0.6.RELEASE-17fixed
stretch, sid3.2.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspring-javasource(unstable)3.0.6.RELEASE-13medium741604
libspring-javasourcewheezy3.0.6.RELEASE-6+deb7u3mediumDSA-2890-1

Notes

http://www.gopivotal.com/security/cve-2014-1904

Search for package or bug name: Reporting problems