CVE-2014-1943

NameCVE-2014-1943
DescriptionFine Free file before 5.17 allows context-dependent attackers to cause a denial of service (infinite recursion, CPU consumption, and crash) via a crafted indirect offset value in the magic of a file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2861-1, DSA-2868-1
NVD severitymedium (attack range: remote)
Debian Bugs738832, 739012
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)squeeze (security), squeeze5.04-5+squeeze5fixed
squeeze (lts)5.04-5+squeeze9fixed
wheezy5.11-2+deb7u6fixed
wheezy (security)5.11-2+deb7u7fixed
jessie1:5.20-2fixed
sid1:5.22+15-1fixed
php5 (PTS)squeeze (security), squeeze5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3-7+squeeze25fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.36-0+deb7u3fixed
jessie5.6.5+dfsg-2fixed
sid5.6.6+dfsg-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)1:5.17-0.1medium738832
filesourcesqueeze5.04-5+squeeze3mediumDSA-2861-1
filesourcewheezy5.11-2+deb7u1mediumDSA-2861-1
php5source(unstable)5.5.10+dfsg-1medium739012
php5sourcesqueeze5.3.3-7+squeeze19mediumDSA-2868-1
php5sourcewheezy5.4.4-14+deb7u8mediumDSA-2868-1

Notes

http://mx.gw.com/pipermail/file/2014/001337.html
https://github.com/glensc/file/commit/3c081560c23f20b2985c285338b52c7aae9fdb0f
https://github.com/glensc/file/commit/cc9e74dfeca5265ad725acc926ef0b8d2a18ee70

Search for package or bug name: Reporting problems