CVE-2014-1947

NameCVE-2014-1947
DescriptionStack-based buffer overflow in the WritePSDImage function in coders/psd.c in ImageMagick 6.5.4 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large number of layers in a PSD image, involving the L%02ld string, a different vulnerability than CVE-2014-2030.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2898-1
NVD severitymedium
Debian Bugs740250

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)stretch (security), stretch1.3.30+hg15796-1~deb9u4fixed
buster, buster (security)1.4+really1.3.35-1~deb10u1fixed
bullseye, sid1.4+really1.3.35+hg16348-1fixed
imagemagick (PTS)stretch8:6.9.7.4+dfsg-11+deb9u8fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u10fixed
buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bullseye, sid8:6.9.11.24+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.20-1unimportant
imagemagicksourcesqueeze8:6.6.0.4-3+squeeze4DSA-2898-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u3DSA-2898-1
imagemagicksource(unstable)8:6.7.7.10+dfsg-1740250

Notes

http://web.archive.org/web/20090120112751/http://trac.imagemagick.org:80/changeset/13736
for graphicsmagick: https://bugzilla.redhat.com/show_bug.cgi?id=1064098#c13
Rendered non-exploitable by fortified source for graphicsmagick

Search for package or bug name: Reporting problems