CVE-2014-1958

NameCVE-2014-1958
DescriptionBuffer overflow in the DecodePSDPixels function in coders/psd.c in ImageMagick before 6.8.8-5 might allow remote attackers to execute arbitrary code via a crafted PSD image, involving the L%06ld string, a different vulnerability than CVE-2014-2030.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2898-1
NVD severitymedium
Debian Bugs740250

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)stretch8:6.9.7.4+dfsg-11+deb9u8fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u10fixed
buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bullseye, sid8:6.9.11.24+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksourcesqueeze8:6.6.0.4-3+squeeze4DSA-2898-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u3DSA-2898-1
imagemagicksource(unstable)8:6.7.7.10+dfsg-1740250

Notes

[squeeze] - imagemagick <not-affected> (DecodePSDPixels function is not present)
squeeze: DecodePSDPixels not present but there was a rewrite from DecodeImage?
http://secunia.com/advisories/56844/

Search for package or bug name: Reporting problems