CVE-2014-1959

NameCVE-2014-1959
Descriptionlib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2866-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls26 (PTS)squeeze, squeeze (security)2.8.6-1+squeeze3fixed
squeeze (lts)2.8.6-1+squeeze5fixed
wheezy2.12.20-8+deb7u2fixed
wheezy (security)2.12.20-8+deb7u3fixed
gnutls28 (PTS)jessie3.3.8-6+deb8u1fixed
stretch, sid3.3.15-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls26source(unstable)2.12.23-12medium
gnutls26sourcesqueeze(not affected)
gnutls26sourcewheezy2.12.20-8mediumDSA-2866-1
gnutls28source(unstable)3.2.11-1medium

Notes

[squeeze] - gnutls26 <not-affected> (does not allow X.509 v1 certificates by default)
https://gitlab.com/gnutls/gnutls/commit/b1abfe3d18
introduced by https://gitlab.com/gnutls/gnutls/commit/60ee8a0eb9975d123002b1cffbefd60a8cd5fae6

Search for package or bug name: Reporting problems