CVE-2014-2015

NameCVE-2014-2015
DescriptionStack-based buffer overflow in the normify function in the rlm_pap module (modules/rlm_pap/rlm_pap.c) in FreeRADIUS 2.x, possibly 2.2.3 and earlier, and 3.x, possibly 3.0.1 and earlier, might allow attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password hash, as demonstrated by an SSHA hash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-977-1
NVD severityhigh
Debian Bugs742820

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeradius (PTS)stretch (security), stretch3.0.12+dfsg-5+deb9u1fixed
buster3.0.17+dfsg-1.1fixed
bullseye3.0.21+dfsg-2.2+deb11u1fixed
bookworm, sid3.0.21+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeradiussourcewheezy2.1.12+dfsg-1.2+deb7u1DLA-977-1
freeradiussource(unstable)2.2.5+dfsg-0.1low742820

Notes

[squeeze] - freeradius <no-dsa> (Minor issue)
http://lists.freebsd.org/pipermail/freebsd-bugbusters/2014-February/000610.html
https://github.com/FreeRADIUS/freeradius-server/commit/0d606cfc29a.patch

Search for package or bug name: Reporting problems