CVE-2014-2055

NameCVE-2014-2055
DescriptionSabreDAV before 1.7.11, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-sabredav (PTS)jessie1.8.10-2fixed
stretch1.8.12-3fixed
buster, sid1.8.12-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
owncloudsource(unstable)6.0.2+dfsg-1high
php-sabredavsource(unstable)1.7.11+dfsg-1high

Notes

https://github.com/fruux/sabre-dav/releases/tag/1.7.11
http://owncloud.org/about/security/advisories/oC-SA-2014-006/

Search for package or bug name: Reporting problems