CVE-2014-2270

NameCVE-2014-2270
Descriptionsoftmagic.c in file before 5.17 and libmagic allows context-dependent attackers to cause a denial of service (out-of-bounds memory access and crash) via crafted offsets in the softmagic of a PE executable.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-145-1, DSA-2873-1, DSA-2943-1
NVD severitymedium (attack range: remote)
Debian Bugs740960
Debian/oldoldstablepackage php5 is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)squeeze, squeeze (security)5.04-5+squeeze5fixed
squeeze (lts)5.04-5+squeeze10fixed
wheezy5.11-2+deb7u6fixed
wheezy (security)5.11-2+deb7u8fixed
stretch, sid, jessie1:5.22+15-2fixed
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19vulnerable
squeeze (lts)5.3.3.1-7+squeeze26fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.44-0+deb7u1fixed
jessie5.6.7+dfsg-1fixed
jessie (security)5.6.12+dfsg-0+deb8u1fixed
stretch5.6.11+dfsg-1fixed
sid5.6.12+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)1:5.17-1medium
filesourcesqueeze5.04-5+squeeze4mediumDSA-2873-1
filesourcewheezy5.11-2+deb7u2mediumDSA-2873-1
php5source(unstable)5.5.10+dfsg-1medium740960
php5sourcesqueeze5.3.3-7+squeeze24mediumDLA-145-1
php5sourcewheezy5.4.4-14+deb7u10mediumDSA-2943-1

Notes

http://bugs.gw.com/view.php?id=313
https://github.com/glensc/file/commit/447558595a3650db2886cd2f416ad0beba965801
http://git.php.net/?p=php-src.git;a=commitdiff;h=a33759fd275b32ed0bbe89796fe2953b3cb0b41f

Search for package or bug name: Reporting problems