CVE-2014-2277

NameCVE-2014-2277
DescriptionThe make_temporary_filename function in perltidy 20120701-1 and earlier allows local users to obtain sensitive information or write to arbitrary files via a symlink attack, related to use of the tmpnam function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)
Debian Bugs740670

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perltidy (PTS)jessie20140328-1fixed
stretch20140328-2fixed
buster, sid20180220-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perltidysource(unstable)20130922-1low740670

Notes

[wheezy] - perltidy <no-dsa> (Minor issue)
[squeeze] - perltidy <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems