CVE-2014-2281

NameCVE-2014-2281
DescriptionThe nfs_name_snoop_add_name function in epan/dissectors/packet-nfs.c in the NFS dissector in Wireshark 1.8.x before 1.8.13 and 1.10.x before 1.10.6 does not validate a certain length value, which allows remote attackers to cause a denial of service (memory corruption and application crash) via a crafted NFS packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2871-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze, squeeze (security)1.2.11-6+squeeze14fixed
squeeze (lts)1.8.2-5wheezy16~deb6u1fixed
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy16fixed
jessie1.12.1+g01b65bf-4fixed
jessie (security)1.12.1+g01b65bf-4+deb8u2fixed
stretch1.12.6+gee1fce6-1fixed
sid1.12.7+g7fc8978-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.10.6-1medium
wiresharksourcesqueeze1.2.11-6+squeeze14mediumDSA-2871-1
wiresharksourcewheezy1.8.2-5wheezy10mediumDSA-2871-1

Notes

[squeeze] - wireshark <not-affected> (Vulnerable code not present)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9672
http://www.wireshark.org/security/wnpa-sec-2014-01.html

Search for package or bug name: Reporting problems