CVE-2014-2283

NameCVE-2014-2283
Descriptionepan/dissectors/packet-rlc in the RLC dissector in Wireshark 1.8.x before 1.8.13 and 1.10.x before 1.10.6 uses inconsistent memory-management approaches, which allows remote attackers to cause a denial of service (use-after-free error and application crash) via a crafted UMTS Radio Link Control packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2871-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18fixed
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u5fixed
jessie1.12.1+g01b65bf-4+deb8u8fixed
jessie (security)1.12.1+g01b65bf-4+deb8u10fixed
stretch, sid2.2.2+g9c5aae3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.10.6-1medium
wiresharksourcesqueeze1.2.11-6+squeeze14mediumDSA-2871-1
wiresharksourcewheezy1.8.2-5wheezy10mediumDSA-2871-1

Notes

[squeeze] - wireshark <not-affected> (Vulnerable code not present)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9730
http://www.wireshark.org/security/wnpa-sec-2014-03.html

Search for package or bug name: Reporting problems