CVE-2014-2284

NameCVE-2014-2284
DescriptionThe Linux implementation of the ICMP-MIB in Net-SNMP 5.5 before 5.5.2.1, 5.6.x before 5.6.2.1, and 5.7.x before 5.7.2.1 does not properly validate input, which allows remote attackers to cause a denial of service via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs742817

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
net-snmp (PTS)stretch5.7.3+dfsg-1.7+deb9u1fixed
stretch (security)5.7.3+dfsg-1.7+deb9u3fixed
buster5.7.3+dfsg-5fixed
bullseye, sid5.8+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
net-snmpsourcesqueeze(not affected)
net-snmpsourcewheezy(not affected)
net-snmpsource(unstable)5.7.2.1~dfsg-3742817

Notes

[wheezy] - net-snmp <not-affected> (Only affects code from 5.5 through 5.7.2)
[squeeze] - net-snmp <not-affected> (Only affects code from 5.5 through 5.7.2)
http://sourceforge.net/p/net-snmp/mailman/message/32026655/
http://sourceforge.net/p/net-snmp/code/ci/a1fd64716f6794c55c34d77e618210238a73bfa1/

Search for package or bug name: Reporting problems