CVE-2014-2286

NameCVE-2014-2286
Descriptionmain/http.c in Asterisk Open Source 1.8.x before 1.8.26.1, 11.8.x before 11.8.1, and 12.1.x before 12.1.1, and Certified Asterisk 1.8.x before 1.8.15-cert5 and 11.6 before 11.6-cert2, allows remote attackers to cause a denial of service (stack consumption) and possibly execute arbitrary code via an HTTP request with a large number of Cookie headers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-455-1
NVD severityhigh
Debian Bugs741313

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)stretch1:13.14.1~dfsg-2+deb9u4fixed
stretch (security)1:13.14.1~dfsg-2+deb9u5fixed
buster1:16.2.1~dfsg-1+deb10u2fixed
bullseye1:16.16.1~dfsg-1fixed
bookworm, sid1:16.16.1~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksourcesqueeze(unfixed)end-of-life
asterisksourcewheezy1:1.8.13.1~dfsg1-3+deb7u4DLA-455-1
asterisksource(unstable)1:11.8.1~dfsg-1741313

Notes

[squeeze] - asterisk <end-of-life> (Unsupported in squeeze-lts)
http://downloads.asterisk.org/pub/security/AST-2014-001.html

Search for package or bug name: Reporting problems