CVE-2014-2287

NameCVE-2014-2287
Descriptionchannels/chan_sip.c in Asterisk Open Source 1.8.x before 1.8.26.1, 11.8.x before 11.8.1, and 12.1.x before 12.1.1, and Certified Asterisk 1.8.15 before 1.8.15-cert5 and 11.6 before 11.6-cert2, when chan_sip has a certain configuration, allows remote authenticated users to cause a denial of service (channel and file descriptor consumption) via an INVITE request with a (1) Session-Expires or (2) Min-SE header with a malformed or invalid value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-781-1
NVD severitylow (attack range: remote)
Debian Bugs741313

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)jessie1:11.13.1~dfsg-2+deb8u5fixed
jessie (security)1:11.13.1~dfsg-2+deb8u6fixed
stretch (security), stretch1:13.14.1~dfsg-2+deb9u4fixed
buster, sid1:16.1.1~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksource(unstable)1:11.8.1~dfsg-1low741313
asterisksourcesqueeze(unfixed)end-of-life
asterisksourcewheezy1:1.8.13.1~dfsg1-3+deb7u5lowDLA-781-1

Notes

[squeeze] - asterisk <end-of-life> (Unsupported in squeeze-lts)
http://downloads.asterisk.org/pub/security/AST-2014-002.html

Search for package or bug name: Reporting problems