CVE-2014-2299

NameCVE-2014-2299
DescriptionBuffer overflow in the mpeg_read function in wiretap/mpeg.c in the MPEG parser in Wireshark 1.8.x before 1.8.13 and 1.10.x before 1.10.6 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a large record in MPEG data.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2871-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze, squeeze (security)1.2.11-6+squeeze14fixed
squeeze (lts)1.8.2-5wheezy15~deb6u1fixed
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy15fixed
jessie1.12.1+g01b65bf-4fixed
stretch, sid1.12.5+g5819e5b-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.10.6-1high
wiresharksourcesqueeze1.2.11-6+squeeze14highDSA-2871-1
wiresharksourcewheezy1.8.2-5wheezy10highDSA-2871-1

Notes

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9843
http://www.wireshark.org/security/wnpa-sec-2014-04.html

Search for package or bug name: Reporting problems