CVE-2014-2310

NameCVE-2014-2310
DescriptionThe AgentX subagent in Net-SNMP before 5.4.4 allows remote attackers to cause a denial of service (hang) by sending a multi-object request with an Object ID (OID) containing more subids than previous requests, a different vulnerability than CVE-2012-6151.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs684388

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
net-snmp (PTS)buster5.7.3+dfsg-5+deb10u2fixed
buster (security)5.7.3+dfsg-5+deb10u4fixed
bullseye (security), bullseye5.9+dfsg-4+deb11u1fixed
bookworm5.9.3+dfsg-2fixed
trixie, sid5.9.4+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
net-snmpsourcewheezy5.4.3~dfsg-2.8
net-snmpsource(unstable)5.7.2~dfsg-3684388

Notes

[squeeze] - net-snmp <no-dsa> (Minor issue)
http://sourceforge.net/p/net-snmp/patches/1113/

Search for package or bug name: Reporting problems