CVE-2014-2323

NameCVE-2014-2323
DescriptionSQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote attackers to execute arbitrary SQL commands via the host name, related to request_check_hostname.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2877-1
NVD severityhigh (attack range: remote)
Debian Bugs741493
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lighttpd (PTS)squeeze, squeeze (security)1.4.28-2+squeeze1.6fixed
squeeze (lts)1.4.28-2+squeeze1.7fixed
wheezy, wheezy (security)1.4.31-4+deb7u3fixed
stretch, sid, jessie1.4.35-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lighttpdsource(unstable)1.4.33-1+nmu3high741493
lighttpdsourcesqueeze1.4.28-2+squeeze1.6highDSA-2877-1
lighttpdsourcewheezy1.4.31-4+deb7u3highDSA-2877-1

Search for package or bug name: Reporting problems