CVE-2014-2338

NameCVE-2014-2338
DescriptionIKEv2 in strongSwan 4.0.7 before 5.1.3 allows remote attackers to bypass authentication by rekeying an IKE_SA during (1) initiation or (2) re-authentication, which triggers the IKE_SA state to be set to established.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2903-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)squeeze (security), squeeze4.4.1-5.6fixed
wheezy4.5.2-1.5+deb7u4fixed
wheezy (security)4.5.2-1.5+deb7u6fixed
jessie, sid5.2.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)5.1.2-4medium
strongswansourcesqueeze4.4.1-5.5mediumDSA-2903-1
strongswansourcewheezy4.5.2-1.5+deb7u3mediumDSA-2903-1

Search for package or bug name: Reporting problems