CVE-2014-2532

NameCVE-2014-2532
Descriptionsshd in OpenSSH before 6.6 does not properly support wildcards on AcceptEnv lines in sshd_config, which allows remote attackers to bypass intended environment restrictions by using a substring located before a wildcard character.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2894-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)squeeze, squeeze (security)1:5.5p1-6+squeeze5fixed
squeeze (lts)1:5.5p1-6+squeeze6fixed
wheezy1:6.0p1-4+deb7u2fixed
wheezy (security)1:6.0p1-4+deb7u1fixed
jessie1:6.7p1-5fixed
stretch, sid1:6.9p1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsource(unstable)1:6.6p1-1medium
opensshsourcesqueeze1:5.5p1-6+squeeze5mediumDSA-2894-1
opensshsourcewheezy1:6.0p1-4+deb7u1mediumDSA-2894-1

Notes

Default sshd_config in Debian has AcceptEnv LANG LC_*
http://marc.info/?l=openbsd-security-announce&m=139492048027313&w=2

Search for package or bug name: Reporting problems