CVE-2014-2708

NameCVE-2014-2708
DescriptionMultiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier allow remote attackers to execute arbitrary SQL commands via the (1) graph_start, (2) graph_end, (3) graph_height, (4) graph_width, (5) graph_nolegend, (6) print_source, (7) local_graph_id, or (8) rra_id parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2970-1
NVD severityhigh
Debian Bugs743565

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)jessie0.8.8b+dfsg-8+deb8u6fixed
jessie (security)0.8.8b+dfsg-8+deb8u9fixed
stretch (security), stretch0.8.8h+ds1-10+deb9u1fixed
buster, buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.10+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisource(unstable)0.8.8b+dfsg-4743565
cactisourcesqueeze0.8.7g-1+squeeze4743565
cactisourcewheezy0.8.8a+dfsg-5+deb7u3DSA-2970-1

Notes

http://bugs.cacti.net/view.php?id=2405 (not yet public)
http://svn.cacti.net/viewvc?view=rev&revision=7439
CVE for all changes to graph_xport.php to ensure that data is numeric

Search for package or bug name: Reporting problems