CVE-2014-2709

NameCVE-2014-2709
Descriptionlib/rrd.php in Cacti 0.8.7g, 0.8.8b, and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified parameters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2970-1
NVD severityhigh
Debian Bugs743565

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)stretch (security), stretch0.8.8h+ds1-10+deb9u1fixed
buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.16+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcesqueeze0.8.7g-1+squeeze4743565
cactisourcewheezy0.8.8a+dfsg-5+deb7u3DSA-2970-1
cactisource(unstable)0.8.8b+dfsg-4743565

Notes

http://bugs.cacti.net/view.php?id=2405 (not yet public)
http://svn.cacti.net/viewvc?view=rev&revision=7439
CVE for all changes to lib/rrd.php to add cacti_escapeshellarg calls

Search for package or bug name: Reporting problems