CVE-2014-2745

NameCVE-2014-2745
DescriptionProsody before 0.9.4 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack, related to core/portmanager.lua and util/xmppstream.lua.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2895-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
prosody (PTS)jessie (security), jessie0.9.7-2+deb8u4fixed
stretch (security), stretch0.9.12-2+deb9u2fixed
buster, sid0.11.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
prosodysource(unstable)0.9.4-1high
prosodysourcewheezy0.8.2-4+deb7u1highDSA-2895-1

Notes

[squeeze] - prosody <no-dsa> (Minor issue)
http://hg.prosody.im/0.9/rev/a97591d2e1ad
http://hg.prosody.im/0.9/rev/1107d66d2ab2

Search for package or bug name: Reporting problems