DescriptionStack-based buffer overflow in cifskey.c or cifscreds.c in cifs-utils before 6.4, as used in pam_cifscreds, allows remote attackers to have unspecified impact via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cifs-utils (PTS)wheezy2:5.5-1fixed
buster, sid, stretch2:6.7-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cifs-utilssourcesqueeze(not affected)
cifs-utilssourcewheezy(not affected)


[squeeze] - cifs-utils <not-affected> (Vulnerable code not present)
[wheezy] - cifs-utils <not-affected> (pam_cifscreds introduced in 6.3)
cifscreds PAM not built in unstable

Search for package or bug name: Reporting problems