CVE-2014-2852

NameCVE-2014-2852
DescriptionOpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows remote attackers to cause a denial of service (performance degradation) via an invalid packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2899-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openafs (PTS)squeeze, squeeze (security)1.4.12.1+dfsg-4+squeeze3fixed
wheezy1.6.1-3+deb7u2fixed
wheezy (security)1.6.1-3+deb7u3fixed
jessie1.6.9-2+deb8u2fixed
jessie (security)1.6.9-2+deb8u3fixed
stretch, sid1.6.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openafssource(unstable)1.6.7-1medium
openafssourcesqueeze1.4.12.1+dfsg-4+squeeze3mediumDSA-2899-1
openafssourcewheezy1.6.1-3+deb7u2mediumDSA-2899-1

Search for package or bug name: Reporting problems